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Microsoft Application Virtualization (App-V) 
5.0 Overview  
 

Objectives 
After completing this lab, you will be better able to: 

 Tour common administration tasks 

 Migrate from prior versions and coexistence with App-V 4.6  

 Enable application to application communication with Virtual Application 
Extensions and Connection Groups 

 Reduce storage requirements for Remote Desktop and VDI with Shared 
Content Store 

 Configure Clients for Reporting and viewing Custom SQL Server Reporting 
Services reports. 

Scenario 
 

Contoso has been using App-V and wants evaluate App-V 5.0. Administrators for 
Contoso are often working at several facilities and on computers that aren’t 
their own and want quick and easy web-based access to perform administrative 
tasks with App-V such as provisioning applications to new users. They would 
also like to automate more of their day to day tasks and offload tasks to junior 
administrators. 

Estimated Time to 
Complete This Lab 

 

90 Minutes 

Computers used in this 
Lab   DC     Client2 - Alan 

  Client2 - Ed                                  AppVSvr 

  Client1                                          RDS1 

  Sequencer1 

The password for the Administrator account on all computers in this lab is: 
Pa$$w0rd 
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Exercise 1 
Tour of Administration Tasks 
 

Scenario 
Contoso has been using App-V and wants evaluate App-V 5.0. Administrators for Contoso are often working at 
several facilities and on computers that aren’t their own and want quick and easy web-based access to perform 
administrative tasks with App-V such as provisioning applications to new users. They would also like to automate 
more of their day to day tasks and offload tasks to junior administrators. 

 

Tasks Detailed Steps 

Complete the following 
task on: 

 AppVSvr 

1. Exploring published 
App-V Packages 

Note: It is recommended to run on a machine with at least 1280 x 1024 or 1440 x 900 

If your resolution is too small to see the full screen: 

 

Note: You can adjust your resolution by right clicking the Virtual machine in the left 
hand pane and hit disconnect. 

Then right click the VM and hit Properties, then click on the Remote Desktop Settings 
tab, uncheck Inherit from parent and click a Remote Desktop Size of 1280 x 1024 or 
higher. 
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Tasks Detailed Steps 

 

Note: Click OK, then double click the VM again to connect to it. 

Try the lab again and it should work with scroll bars 

a. Log on to the AppVSvr machine as user Contoso\Administrator with password 
Pa$$w0rd. 

b. Access the App-V Server Management Console by opening Internet Explorer 
from the taskbar and browsing to http://localhost:888/Console.html 

Note: The App-V Server Management Console is now a web site powered by 
Microsoft Silverlight.  Maximize the browser window for easier navigation. 

c. The Packages panel currently lists a number of packages including the 
adobereader9_4 package.  Notice that the status of the adobereader9_4 package 
is displayed as published. 

Note:  This indicates that the application is available to the appropriate users. 

Complete the following 
task on: 

 AppVSvr 

2. Assigning Users 

a. Right-click the adobereader9_4 package and select edit active directory access. 

b. Notice that the Contoso\Research domain group has been Granted Access. 

c. Click Close. 

Note: The sub-panel now changes to the properties sub-panel for the adobereader9_4 
package. 

Complete the following 
task on: 

  AppVSvr 

3. Examining the 
Default Configuration 
of a Package 

a. In the upper Packages panel, right-click the Adobereader9_4 package and select 
edit default configuration. 

Note: The Default Configuration sub-panel appears. 

b. In the Default Configuration sub-panel, select the Applications node. 

Note: The Adobe Reader 9 application is shown as included in this package and that it 
is enabled for distribution.  Had this been a package that contained a suite of 
applications, each application in the suite would be listed and could be enabled or 
disabled for distribution individually. 
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Tasks Detailed Steps 

c. In the Default Configuration sub-panel, select the Shortcuts node. 

d. Scroll-down through the Shortcuts sub-window. Notice the shortcuts that are 
defined. Scrolling further takes you to controls to Add new shortcuts and Edit 
existing shortcuts. 

e. In the Default Configuration sub-panel, select the File Types node. 

f. Scroll-down through the File Types sub-sub-window and notice the various File 
Type Associations that are included in this package and their values. 

g. In the Default Configuration sub-panel, select the Advanced node. 

Note: The options to export the current configuration set to an XML file as well as 
import a previously exported .xml configuration file for this package. 

h. In the Default Configuration sub-panel, click Close. 

Complete the following 
task on: 

  AppVSvr 

4. App-V Servers 

a. In the left-hand tree, select the Servers node. 

Note:  The Servers panel appears on the right. 

b. Notice the Register New Server option in the upper-right quadrant of the panel.  
This allows you to register additional App-V publishing servers. 

c. Right-click the CONTOSO\APPVSVR shown in the list. Notice the option to 
unregister existing App-V Publishing Servers. 

Note:  DO NOT unregister the server. 

Complete the following 
task on: 

 AppVSvr 

5. App-V Admins 

a. In the left-hand tree, select the Admin (gear icon) node. 

Note: The Administrators panel appears to the right. 

b. Notice the Add Administrator option in the upper-right quadrant of the panel.  
This allows you to define additional users and groups as administrators within the 
App-V Management Server. 

Complete the following 
task on: 

 Client2 

6. No Q: Drive 

a. Log on to the Client2 machine as user Contoso\Ed with password Pa$$w0rd. 

b. Click the File Explorer tile. 

c. In the left-hand tree, select the Computer node. 

d. Notice that there is no longer Q:\ drive present as there has been in previous 
versions of App-V. App-V 5.0 does not require a dedicated drive letter. 

Note:  The R: drive is a DaRT recovery image location providing additional support 
options. 

e. Close Windows Explorer. 

Complete the following 
task on: 

 Client2 

7. Explore the App-V 
5.0 client interface 

a. Mouse to the upper right hand corner to raise the Charms Bar. In the Charms Bar 
select the Search charm. 

b. In the Apps search field enter Virtual, in the App results click the Microsoft 
Application Virtualization Client app. 

Note:  This is the App-V 5.0 Client Management Console 

c. In the Overview pane, notice the 3 tiles that represent the 3 main client-side 
operations: Update, Download all virtual applications and Work Offline. 

Note: Each tile can be clicked to manually perform the task described in the title of 
each tile. 

d. Select the Virtual Apps pane by clicking the word VIRTUAL APPS.  In the Virtual 
Apps pane, you can see a list of all packages currently available to the user. 

Note:  If no packages are shown, the hosted virtual machine may be experiencing 
slower than normal performance.  Wait about 20 seconds then press F5 to refresh. 

e. Select the App Connection Groups pane by clicking on the words APP 
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Tasks Detailed Steps 

CONNECTION GROUPS.  In the Connection Groups pane, you can see the 
relationships developed to allow bi-directional communication for related but 
separately packaged applications.  

f. Notice that there are currently no assigned Connection Groups for this user.  We 
will create one later. 

g. Close the App-V Client Management Console. 

Complete the following 
task on: 

 Client2 

8. Package Format 

a. On the Desktop, right-click the icon for XMLNotepad and select Properties. 

b. Notice that the shortcut target for XMLNotepad points directly to the application 
executable. In App-V 5.0, virtual applications leverage Windows standards, and 
are stored right in the local file system and need no “launcher.” 

c. Click Open File Location 

d. Click Cancel to close the XMLNotepad property window. 

Note: Windows Explorer is now showing the virtualized application’s files. Notice the 
gray “x” icons.  Those icons indicate that the files are sparse files, not the actual files.  
They are merely placeholders because the application has not yet been streamed and 
cached on the client. 

e. On the Desktop launch XMLNotepad. 

Note: This is the icon to launch virtualized XMLNotepad. 

f. When XMLNotepad opens, close XMLNotepad 

g. Back in the Windows Explorer window, notice that the file icons have changed 
from the “gray x” icons to their normal color icons.  This indicates that the files 
are now the actual files because the application was streamed and cached on the 
client upon the first launch of the application.  Close Windows Explorer. 

Complete the following 
task on: 

 Client2 

9. Publishing 
PowerPoint Viewer 
and Excel Viewer 
packages on the 
client using 
PowerShell. 

Note: The commands used in the task have also been placed in C:\LabCommands.txt 
so you can copy/paste rather than type if you prefer. 

a. Continuing on Client2  as user Contoso\Ed  

b. Mouse to the upper right hand corner to raise the Charms Bar. In the Charms Bar 
select the Search charm. 

c. In the Apps search field enter Powershell. 

d. In the Apps search results, right click the Windows PowerShell app. At the 
bottom of the screen, click Run as Administrator. 

e. Click Yes on the UAC window. 

f. Use the following commands to add the App-V package for PowerPoint Viewer via 
PowerShell.  At the PowerShell prompt, enter the following commands: 

Import-Module AppvClient 

g. This command makes the App-V Client commandlets available for use in the 
PowerShell session 

Add-AppvClientPackage –Path 

\\AppVSvr\content\Microsoft_PowerPoint_Viewer_2007\Microsoft_PowerPoint_View

er_2007.appv 

h. The Add-AppvClientPackage command makes the App-V package available to the 
local client. 

Mount-AppvClientPackage –Name “Microsoft_PowerPoint_Viewer_2007” 

i. The Mount-AppvClientPackage command instructs the App-V Client to download 
and cache 100% of the application.  This step may take a few moments.  

Publish-AppvClientPackage –Name “Microsoft_PowerPoint_Viewer_2007” –Global 

j. The Publish-AppvClientPackage command makes the App-V package visible to 



Microsoft Application Virtualization (App-V) 5.0 Overview 

 

Page 6 of 17 

Tasks Detailed Steps 

users. The –Global switch allows all users of this client to access the package. 

k. Mouse to the upper-right hand corner to raise the Charms Bar. In the Charms Bar 
select the Search charm. 

l. In the Apps search field type PowerPoint Viewer 

Note:  The presence of this app means the application has been published. 

m. For greater ease, the above three commands can be combined using pipes | into 
a single command line. Raise the Charms Bar, select the Start charm. Click the 
Desktop tile. At the already open PowerShell prompt, enter the following 
command: 

Add-AppVClientPackage –path 

\\AppVSvr\content\Microsoft_ExcelViewer_2007_MNT\Microsoft_ExcelViewer_2007_

MNT.appv |Mount-AppVClientPackage|Publish-AppvClientPackage –Global 

Note:  The example above combines Adding, Mounting and Publishing the App-V 
package into a single command line. The output from previous commands is used as 
the input for subsequent commands. This is why, in the example above, there was no 
need to type the App-V package path for the Mount command and no need to type 
the package name for the Publish command. 

n. Mouse to the upper-right hand corner to raise the Charms Bar. In the Charms Bar 
select the Search charm.  

o. In the Apps search field type Office Excel Viewer. Click the Microsoft Office Excel 
Viewer app. 

Note: Excel Viewer launches. 

p. Close Excel Viewer. 

q. Logoff Client2. 



Microsoft Application Virtualization (App-V) 5.0 Overview 

 

Page 7 of 17 

Exercise 2 
Migration from prior versions and coexistence with App-
V 4.6 
 

Scenario 
Contoso would like to deploy App-V 5.0 to a set of users for trial.  Ed, an administrator from Contoso, will convert 
an App-V application from a prior version of App-V to App-V 5.0 and prepare it for use in the new environment. As 
part of their migration strategy, Contoso will provide both App-V 4.6 and App-V 5.0 applications to their users until 
their migration to App-V 5.0 is complete. 

 

Tasks Detailed Steps 

Complete the following 
task on: 

 Client1 

1. Show that 4.6 SP2 
Client and App-V 5.0 
Client are both 
installed 

a. Log on to the Client1 machine as user Contoso\Ed with password Pa$$w0rd. 

b. Open Windows Explorer and in the left-hand tree, select the Computer root 
node. 

c. Notice the presence of a Q:\ drive.  This shows that the App-V 4.6 Client is 
installed. 

d. Close Windows Explorer. 

e. From the Start Menu, select Control Panel, then Administrative Tools. 

f. Open the Application Virtualization Client and select Yes at the UAC prompt. 

g. Click on Help and About Application Virtualization Client…. Notice the version is 
4.6.2.24020 

h. Click on OK and close the App-V 4.6 SP2 Client console. 

i. From the Start Menu, select All Programs, Microsoft Application Virtualization 
Client, Microsoft Application Virtualization.  

j. Click About and notice the version 5.0.285.0 

k. Click on Close and close the App-V 5.0 Client console. 

Complete the following 
task on: 

 Client1 

2. Show the virtual App 
running in the 4.6 
Client. 

a. Click Start > All Programs > App-V 4.6 Applications> Orca 

b. The Orca application opens. 

c. Notice the App-V 4.6-style progress bar in the lower-right corner of the screen as 
Orca launches. 

d. Bring the Control Panel, Administrative Tools window back to the foreground and 
then double click Application Virtualization Client. Click Yes at the UAC window. 

e. In the App-V 4.6 Client management console, select the Applications node.   

f. Notice that the Orca application package status shows In Use 100%.  This 
demonstrates that the application has opened within the App-V 4.6 Client. 

g. Logoff Client1. 

Complete the following 
task on: 

  Sequencer1 

3. Use the App-V 5.0 
Package Converter to 
convert the 4.6 

Note: The commands used in the task have also been placed in C:\LabCommands.txt 
so you can copy/paste rather than type if you prefer. 

a. Log on to the Sequencer1 machine as user Contoso\Administrator with password 
Pa$$w0rd. 

b. Click Start > All Programs > Accessories > Windows PowerShell > Windows 
PowerShell 

c. At the PowerShell prompt, enter the following commands to perform the 
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package to an App-V 
5.0 package. 

conversion: 

Import-Module AppVPkgConverter 

ConvertFrom-AppvLegacyPackage –SourcePath “\\DC\Content\Microsoft Orca” –

DestinationPath “C:\LabFiles” 

d. When the conversion has completed, enter the following command to create the 
destination folder for the converted package on the App-V 5.0 server: 

MD “\\AppVSvr\content\Microsoft Orca” 

e. Enter the following command to copy the converted package to the destination 
folder on the App-V 5.0 server (all one line): 

Copy “C:\LabFiles\*.*” “\\AppVSvr\content\Microsoft Orca” 

Complete the following 
task on: 

  Sequencer1 

4. Publish the app on 
the App-V 5.0 Server. 

a. Access the App-V Server Management Console by opening Internet Explorer and 
selecting the Application Virtualization Console favorite. 

b. Maximize the IE window. 

c. By default the Management console opens to the PACKAGES page. 

d. Click ADD or UPGRADE PACKAGES. 

e. Click Browse, enter \\AppVSvr\content and click Open. 

f. Browse to and select Microsoft Orca\Microsoft Orca.appv click on Open and click 
Add. 

g. When the import operation completes in the Package Import panel, click Close. 

Note: The Packages panel now lists the Microsoft Orca package.  Notice that the 
status is displayed as unpublished. 

h. Right-click the Microsoft Orca package and select edit active directory access. 

i. The Find Valid Active Directory Groups and Grant Access sub-panel appears. 

j. Enter: Contoso\IT and click Check. 

k. Click to select the IT [Contoso.com] result and click Grant Access. 

Note: The IT [Contoso.com] entry is now listed in the AD Entities With Access column. 

l. Click Close. 

m. In the upper Packages panel, right-click the Microsoft Orca package and select 
publish. 

Note:  The package status now displays with green as published and is ready to be 
streamed by users in the Contoso\IT group that was specified earlier. 

Complete the following 
task on: 

 DC 

5. De-provision the 
Orca application 
from the App-V 4.5 
SP2 Server. 

a. Log on to DC as user Contoso\Administrator with password Pa$$w0rd. 

b. Click Start > Administrative Tools > Application Virtualization Management 
Console. 

c. Expand dc.contoso.com, select the Applications node, right-click the Orca 
application and select Properties. 

d. Un-check the Enabled box to disable the application and click OK. 

Complete the following 
task on: 

 DC 

6. Examine coexistence 

a. Log on to the Client1 machine as user Contoso\Ed with password Pa$$w0rd. 

b. Click Start > All Programs and notice that the App-V 4.6 Applications folder and 
the Orca shortcut that was in that folder is no longer present. 

c. Click Start. Right click the Orca shortcut and click Properties. 

d. Examine the path shown in the Target field.  Notice that this shows a location in 
the 5.0 client location.  Click Cancel. 

e. Click Start > Orca to launch Orca from within the App-V 5.0 Client to show that 
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Tasks Detailed Steps 

the converted package launches successfully. 

f. Logoff Client1. 
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Exercise 3 
Enabling application to application communication with 
Virtual Application Extensions and Connection Groups 
 

Scenario 
Now that Contoso has migrated applications to App-V 5.0, they would like to take advantage of flexible 
virtualization options that enable App-V applications to communicate with each other and with traditionally 
installed applications.  

A new feature in the App-V v5 Management Server is the ability to publish individual resources such as packages 
and connection groups to machines rather than users.  They would also like to examine the v5 feature of 
publishing a connection group to the Client2 machine where the applications have already been published to the 
user. 

Tasks Detailed Steps 

Complete the following 
task on: 

 Client2 

1. Show an email link 
within Adobe Reader 
9 launching a 
separately virtualized 
outlook mail client. 

a. Log in to machine Client2 as user Contoso\Alan with password Pa$$w0rd 

b. Click the Desktop tile. 

c. Right-click the App-V 46 CM2012.PDF file and select Open with > Adobe Reader 
9.4. This instance of Adobe Reader has been virtualized. 

d. If the EULA appears click Accept. 

e. On page one, scroll down and click the mailto link labexample@contoso.com and 
click Allow at the Security Warning. 

Note:  Virtualized Microsoft Outlook 2013 will open to create a new email message.  
Depending on the performance of the hosted VMs this may take a few moments to 
open. 

f. Minimize but do not close the Untitled Message window. 

g. Mouse over to the upper-right corner of the Desktop to raise the Charms bar.  
Click the Search charm. 

h. The Apps menu appears. Click an empty area near the top of the Apps menu to 
shrink the search bar revealing the shortcut for the Microsoft Application 
Virtualization Client console.  (Orange cube icon) 

i. Click the Microsoft Application Virtualization Client console. 

j. The App-V Client Virtual Application Management console will open.  Select the 
VIRTUAL APPS pane. 

k. Notice that the Office 15 and AdobeReader9_4 package status shows that they 
are currently In Use. 

Note:  This demonstrates Virtual Application Extension where virtual applications can 
interact with local or other virtual applications. The virtual application “MAILTO” 
protocol handler has been registered natively and is available to local and other 
virtual applications.  

l. Keep the Virtual Application Management console open. 

m. Close the Untitled Message window and click No when asked to save. 

n. Close Adobe Reader 9. 

Complete the following 
task on: 

a. Switch to AppVServer. Continue using Contoso\Administrator. 

b. Select the Packages pane; notice that there are separate Microsoft Office 15 and 
Semblio Add-In packages. 
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Tasks Detailed Steps 

 AppVServer 

2. Show that virtual 
applications are 
isolated by default 

Note: Microsoft Semblio is an Add-in for Microsoft Word which, when installed, adds 
an Academic tab to the Office Ribbon. 

Complete the following 
task on: 

  Client2 

3. Show that virtual 
applications are 
isolated by default 

a. Switch to Client2. Continue using Contoso\Alan. 

b. Notice the Microsoft Semblio Authoring shortcut on the desktop.  

c. Right-click the Semblio shortcut and click properties, notice the path to the 
executable as being an App-V 5.0 path.  

d. Mouse over to the upper-right corner of the Desktop to raise the Charms bar.  
Click the Start charm. 

e. Scroll to the right in the Start menu and click the Word 2013 app. 

f. Microsoft Word opens.  Click the Blank Document template. 

g. Notice that in the Ribbon there is no tab labeled Academic. 

Note:  Notice that although we have seen in the App-V Management console that 
both Office and Semblio are present on this machine; the Word application cannot 
access the Semblio plug-in because Semblio was virtualized into a separate virtual 
application package. 

h. Close Microsoft Word 2013 and Microsoft Semblio Authoring Properties. 

Complete the following 
task on: 

  AppVSvr 

4. Add two separately 
virtualized 
applications into the 
same connection 
group and publish 
the connection group 
to the Client2 AD 
group which contains 
the computer 
account for the 
Client2 machine. 

a. Switch to AppVSvr 

b. In the App-V Server Console in the left-hand tree, select Connection Groups. 

c. Click the ADD CONNECTON GROUP link in the upper-right corner. 

Note:  New Connection Group appears in the list 

d. Click on the name of the New Connection Group, a rename box appears.  
Rename the group to Office with Semblio and press enter to accept the rename. 

e. In the lower pane, next to the CONNECTED PACKAGES header, click the EDIT link. 

f. In the lower right PACKAGES pane: 

g. Select the Microsoft Office 15 package and click the Left Arrow icon. 

h. Select the Semblio Add-in package and click the Left Arrow icon. 

i. Click Apply. 

j. Click Close. 

k. In the lower pane, next to the AD ACCESS header, click the EDIT link. 

l. In the text field in the lower pane, enter Contoso\CLIENT2 and click Check. 

m. Select CLIENT2 [Contoso.com] and click Grant Access. 

n. Click Close. 

o. In the upper pane, right-click the Office with Semblio connection group and 
select Publish. 

Note:  The connection group was just published to a domain group containing a 
machine account.  Publishing data targeted to machines can only be retrieved using a 
Global refresh.  For this reason the next step will be to log off and back on to Client2 
to perform a global refresh which operates in the context of the machine rather than 
the standard context of the user. 

Complete the following 
task on: 

a. Switch to Client2. 

b. Logoff from Client2. 

c. Logon to Client2 as user Contoso\Alan with password Pa$$w0rd 
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 Client2 

5. Show the two 
separately virtualized 
applications 
interacting 

d. Scroll to the right in the Start menu and click the Word 2013 app. 

e. Microsoft Word opens.  When an application is brought in to a connection group 
it will return to a ‘first run’ operating condition.  As a result you are prompted to 
configure updates.  Select Ask me later and click Accept. 

f. Click the Blank Document template. 

g. Notice that in the Ribbon there is now a tab labeled Academic.   

Note:  If you experience problems with the Academic tab not being present.  Logoff 
and logon to Client 2 as Alan and reopen Word 2013. 

h. In the ribbon, select the Academic tab. 

Note:  Notice now that the Semblio functions are present within word.  When 
separate virtual application packages are combined in a Connection Group, they open 
within the same virtual environment and can access each other’s resources.  

i. Close Microsoft Word 2013. 
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Exercise 4 
Reducing storage requirements for Remote Desktop and 
VDI with Shared Content Store 
 

Scenario 
Contoso already has a large Session Virtualization implementation and are looking into VDI.  They have already 
identified that the storage requirements across 150 Session based servers as well as the potential for hundreds to 
thousands of VDI desktops will make it cost prohibitive.  The App-V and Remote Desktop Services administrators 
are setting up and testing the new Shared Content Store feature in 5.0. 

 

Tasks Detailed Steps 

Complete the following 
task on: 

 RDS1 

1. Publish virtualized 
XMLNotepad as an 
RDS WebApp 

Note: The commands used in the task have also been placed in C:\LabCommands.txt 
so you can copy/paste rather than type if you prefer. 

a. Log on to RDS1 as user Contoso\Administrator with password Pa$$w0rd 

b. Mouse over to the upper-right hand corner of the Desktop to raise the Charms 
Bar.  In the Charms Bar, select the Search charm. 

c. In the Apps search field type Powershell, press Enter. Click the Windows 
Poweshell tile. 

d. At the PowerShell prompt enter: 

Import-Module AppVClient 

Add-AppvClientPackage –path \\AppVSvr\content\XMLNotepad\XMLNotepad.appv | 

Publish-AppvClientPackage –Global 

e. Close Windows PowerShell. 

f. Start Server Manager from the taskbar (furthest left icon). 

g. Wait for the Server Manger app to load all the services configured on the server. 
Once completed, on the left-hand side, click Remote Desktop Services. 

h. On the left-hand side click Collections. It may take a moment to load all available 
collections. Click QuickSessionCollection.  

i. Under the RemoteApp Programs section, click Tasks, click Publish RemoteApp 
Programs. 

j. The Publish RemoteApp Programs wizard will now populate all programs 
currently available for publishing. Scroll-down the application list and notice the 
virtual XML Notepad 2007 application is displayed. Select the box next to XML 
Notepad 2007 and click Next. 

k. Click Publish. 

l. Once the publishing has completed, click Close. 

m. Close Server Manager. 

Complete the following 
task on: 

 RDS1 

2. Show published 
application on client 
consists of just 

a. Right-click the XML Notepad 2007 shortcut on the Desktop and select Properties. 

b. Select Open File Location. 

c. Click Cancel to close the XMLNotepad property window. 

d. Right-click the Help.chm file and select Properties and notice the Size is listed as 
476 KB however the Size on Disk shows only 4KB is taken.  This is showing that 
the package has not been cached on the client 

e. Click Cancel. 
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sparse files and is not 
streamed to the 
client. 

f. Notice the gray x icons next to files showing that these are only sparse files. 

Complete the following 
task on: 

  RDS1 

3. Launch application.  
Show local 
application is still just 
sparse file 
demonstrating that 
the app is not cached 
locally. 

a. On the Desktop launch the XMLNotepad shortcut. 

Note: This is the icon to launch virtualized XMLNotepad. 

b. When XMLNotepad opens, switch to Windows Explorer 

c. Notice that the file icons for the application are still shown with the “gray x” icons 
showing that they are still sparse files.  This indicates that the application is 
running on the RDS1 machine but has not been cached on the RDS1 machine. 

d. Close XMLNotepad. 

Complete the following 
task on: 

  Client1 

4. Launch XMLNotepad 
from RDS WebApp. 

a. Log on to the Client1 machine as user Contoso\Ed with password Pa$$w0rd 

b. Open Internet Explorer  and in the favorites list, select RD Web Access 
(https://RDS1.contoso.com/rdweb) 

c. Enter the user as Contoso\Ed with password Pa$$w0rd and click Sign-in. 

d. Launch the XmlNotepad web app. 

Note: Accept any certificate notifications and XmlNotepad WebApp opens.  In the 
demo environment, this process may take a few moments. 

e. Once XMLNotepad has opened leave it open and switch back to the RDS1 
machine. 

f. Refresh the view of the Root folder in Windows Explorer. 

g. Notice that the file icons for the application are still shown with the “gray x” icons 
showing that they are still sparse files.  This indicates that the application is 
running on the RDS1 machine but has not been cached on the RDS1 machine. 
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Exercise 5 
Configuring Clients for Reporting and viewing Custom 
SQL Server Reporting Services reports. 
 

Scenario 
Contoso has setup App-V servers and has clients running virtual applications daily. The App-V administrators have 
installed SQL Reporting Services on the App-V management server to support reporting. They have recently 
starting deploying and updating applications and need to ensure delivery has been successful. There has been a 
recent hotfix to the App-V client and they need to determine which machines have yet to receive the patch. 
Additionally, they wish to track which applications are not being frequently used in order to reduce licensing costs 
in their company. 

 

Tasks Detailed Steps 

Complete the following 
task on: 

 Client1 

1. Setup Client1 to 
report XML files to 
AppVSvr. 

Note: The commands used in the task have also been placed in C:\LabCommands.txt 
so you can copy/paste rather than type if you prefer. 

a. Switch to the Client1 machine. 

b. Close all open windows. 

c. Click Start > All Programs > Accessories > Windows PowerShell > Windows 
PowerShell | Right Click > Run as Administrator 

d. Click Yes at the UAC prompt. 

e. At the PowerShell prompt, enter the following commands to configure reporting: 

Import-Module appvclient 

Set-AppVClientConfiguration                                –ReportingEnabled 1                                              

–ReportingStartTime 1                                           –ReportingRandomDelay 60                                  

–ReportingInverval 1                                              –ReportingServerURL 

\\AppVSvr\apppvreporting 

Note: The parameters in this command line include the following: 

ReportingEnabled: When set to 1, this enables reporting on the client 

ReportingStartTime: Sets when the client will start reporting data. This is a 24 hour 
format (0-23) 

ReportingRandomDelay: Specifies a delay time for data to be sent to the server. The 
client will randomly generates a delay time between 0 and this parameter, then waits 
that duration from the ReportingStartTime before sending data. This helps prevent 
overloading the App-V management server. 

ReportingInterval: This specifies how often data is sent to the server. 

ReportingServerURL: When set to a UNC path, the client will generate an XML file and 
upload it to the specified location. When set to an App-V Reporting Server URL, it will 
automatically upload the data into the AppVReporting database. 

Complete the following 
task on: 

 Client1 

2. View the reporting 

a. Click Start > All Programs > Accessories > System Tools > Task Scheduler. 

b. In the right-hand pane, expand Task Scheduler Library, expand Microsoft, expand 
AppV, click Reporting 

c. Notice the reporting task that has been created. It runs at 1:00 AM every day 
(ReportingStartTime = 1), with the next run time set to a random time anywhere 
from 1AM to 2AM (ReportingRandomDelay = 60).  
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Tasks Detailed Steps 

Scheduled task d. Close Task Scheduler. 

Complete the following 
task on: 

  Client1 

3. Manually send report 
data to AppVSvr 

Note: The commands used in the task have also been placed in C:\LabCommands.txt 
so you can copy/paste rather than type if you prefer. 

a. In the open PowerShell window, enter the following command to manually 
submit a report to AppVSvr. 

Send-AppVClientReport 

b. Close PowerShell 

c. Logoff Client1 

Complete the following 
task on: 

  AppVSvr 

4. View the reporting 
data on AppVSvr 

a. Switch to AppVSvr. Continue using Contoso\Administrator. 

b. Open Windows Explorer, navigate to C:\AppVReporting. 

c. Notice there is a single file in this location. This the reporting file submitted by the 
client. Right click the file and select Open With > Notepad. 

d. In Notepad, click Format > Word Wrap. 

Note: This file contains information on a client regarding what packages have been 
loaded, when they have been run, and basic information regarding the client.  

e. Close Notepad. 

Complete the following 
task on: 

 AppVSvr 

5. Open SRSS Home 
Page 

a. Continuing on AppVSvr as Contoso\Administrator. 

b. Open Internet Explorer from the taskbar. 

c. In Favorites, click the link for SSRS Home. 

Note: This may take several minutes to load.  

To save time in the demo, reporting data has been prepopulated into the reporting 
database. 

Complete the following 
task on: 

 AppVSvr 

6. View all the client 
versions in the 
environment. 

a. Click the report icon for the AppV Client Versions. 

Note: All of the clients currently in our environment are all running the latest release 
of the App-V client. In production environments, this report can be utilized to find 
clients that need upgrades or hotfixes.  

b. Scroll to the right to see the App-V Client versions. 

c. Click anywhere on the pie graph. 

d. Notice that the reporting feature allows you to see specific data regarding the 
client’s operating system versions. 

e. In the top-left corner, click Home. 

Note:  In a production environment with thousands of clients, this report could be 
used to evaluate that all client computers were running on the same App-V Client 
version. 

Complete the following 
task on: 

 AppVSvr 

7. View the Average 
Use times for specific 
applications in your 
environment. 

a. Click the report Average Use Time for All Applications 

b. Notice average use times can be determined for App-V applications. Click the blue 
bar to the right of Adobe Reader 9. 

c. Notice usage times can be broken down on a per-machine basis. Click the blue 
bar to the right of Client1.contoso.com. 

d. Notice usage times can be broken down on a per-user basis.  

Note: In a production environment, you can find applications that are not being used 
in your environment. This can be helpful in finding users that are licensed for high cost 
applications, but rarely use them. 

e. In the top-left corner, click Home. 

Complete the following a. Click the report Package Versions. 
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Tasks Detailed Steps 

task on: 

 AppVSvr 

8. View the status of a 
package update. 

b. In the Package Name drop down, select XMLNotepad. 

c. Click View Report. 

d. Notice there are two versions of an application deployed. This indicates a user has 
not launched an updated application yet, or there is a problem with the client. 
Click the blue section of the pie graph. 

e. Notice again the reporting feature allows viewing specific machine information. 

Note: In a production environment this data can be useful to accurately determine 
the status of an update rollout. 

f. [End of Demo] 

 


